Support

Start a conversation

Minimum requirements to run RealTime Services 6.6 with Transport Layer Security 1.2

Summary

If you would like to prepare your Exchange environments for the upcoming Transport Layer Security (TLS) 1.2 configuration guidance, please align yourself by auditing your current deployment against the below set of requirements:

Exchange Server 2019

Exchange Server 2019 can work out of the box with TLS 1.2 without any configuration or requirements.

Exchange Server 2016

  • Install Cumulative Update (CU) 8 in production for TLS 1.2 support and be ready to upgrade to CU9 after its release if you need to disable TLS 1.0 and TLS 1.1.
  • Install the newest version of .NET and associated patches supported by your CU (currently 4.7.1).

Exchange Server 2013

  • Install CU19 in production for TLS 1.2 support and be ready to upgrade to CU20 after its release if you need to disable TLS 1.0 and TLS 1.1.
  • Install the newest version of .NET and associated patches supported by your CU (currently 4.7.1).

Exchange Server 2010 or older

  • Out of support. There is no path forward and you should be planning a migration to Exchange Online or a modern version of Exchange Server on-premises.

For other related information on getting ready for TLS 1.2, refer to this article.

Note: RealTime Services 6.6 does not support Exchange Server 2010 and older versions. (Please refer to this article for RealTime Services 6.6 requirements)

Properties

Applies to: RTS 6.6+

Reference: TFS #178150

Knowledge base ID: 0242

Last updated: Apr 19, 2022

Choose files or drag and drop files