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Forms-Based Authentication & Resource Finder failure after RC 4.3 HF4 Upgrade when using HTTP

Modified on Fri, 21 Mar at 10:25 AM

Symptom

After upgrading to Resource Central 4.3 HF4, users are unable to log in to the Resource Central backend with the system account, and Resource Finder fails to load.

 

Cause

As part of our ongoing security enhancements, Resource Central 4.3 HF4 enforces login via HTTPS only. HTTP login is no longer supported by default.

 


Workaround

1. Relax SSL requirements in web.config

To re-enable HTTP support in RC 4.3 HF4, follow these steps:


Step 1: Create a backup copy of the web.config file

Navigate to the installation folder (default location: C:\inetpub\wwwroot\ResourceCentral) and create a backup copy of the web.config file before proceeding with any changes in the following steps.


Step 2: Open the web.config file


Step 3: Remove the HTTPS requirement

Locate and remove the following line: 

<httpCookies requireSSL="true" />


Step 4: Modify the following line  

Locate and change the following line:

<forms cookieless="UseDeviceProfile" loginUrl="admin/login" name=".RCAUTH" cookieSameSite="Lax" requireSSL="true" /> 

To

<forms cookieless="UseDeviceProfile" loginUrl="admin/login" name=".RCAUTH" cookieSameSite="Lax" /> 

 

2. Apply patch to fix Resource Finder load issue

To fix the Resource Finder load issue, follow these steps:

Step 1: Create backup copies of the Resource Central.dll and Login.cshtml files

  • Navigate to the installation folder and open the bin folder (the default location is: C:\inetpub\wwwroot\ResourceCentral\bin), where you will find the Resource Central.dll file. Then, create a backup copy of the Resource Central.dll file in a different location.
  • Navigate to the installation folder and open the Login folder (the default location is: C:\inetpub\wwwroot\ResourceCentral\Mvc\Admin\Views\Login., where the Login.cshtml file is located. Then, create a backup copy of the Login.cshtml file in a different location.

 

Step 2: Download and unzip the patch files

Download the zipped file you received in the attachment and unzip it. In the extracted folder, you will find the following two files:

  • Resource Central.dll
  • Login.cshtml

 

Step 3: Replace the existing files with the new ones

  • In the C:\inetpub\wwwroot\ResourceCentral\bin folder, replace the existing Resource Central.dll file with the one you downloaded.
  • In the C:\inetpub\wwwroot\ResourceCentral\Mvc\Admin\Views\Login folder, replace the existing Login.cshtml file with the one you downloaded.

 

After making these changes, restart the IIS server to apply the modifications.

 


Properties

Applies to: RC 4.3 HF4

Reference: TFS #412887

Knowledge base ID: 0340

Last updated: Mar 21, 2025


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