Symptom
Information about availability of attendees in appointments with “working elsewhere” status cannot be retrieved and returned with blank status value.
This is how the appointment with “working elsewhere” status is shown in Outlook:
And this is how attendee status of this appointment is shown in ResourceFinder:
If this function works properly, the attendee should have the status highlighted in the following figure:
Cause
RC uses "GetUserAvailability" function of RTS to get free/busy data of users in Exchange.
But there is a limit in Exchange Web Service: it does not support getting availability data of “Working Elsewhere” status in Exchange Online. Therefore, when RTS sends a request to EWS, it cannot retrieve availability of meetings/appointments with "Working Elsewhere" status.
Resolution
This has been confirmed as a defect and will be fixed later with the improved managed API provided by Microsoft.
Properties
Applies to: RC 3.7.10 or newer versions, Exchange Online and Exchange 2013
Fixed in: RC 3.8 SR1 RC3 and RTS 6.4.17.118
Reference: TFS #11410
Knowledge base ID: 0103
Last updated: Feb 23, 2016
Was this article helpful?
That’s Great!
Thank you for your feedback
Sorry! We couldn't be helpful
Thank you for your feedback
Feedback sent
We appreciate your effort and will try to fix the article